Sign Up / Log In

What Version Of Mac OS X Do I Need To Upgrade To Snow Leopard?

Question:

I have Mac OS X 10.4. Can I buy the Snow Leopard upgrade?
- Asked by Leroy M. February 15th, 2011

Answer:

Unfortunately, in order to upgrade to Mac OS X 10.6 Snow Leopard you need to have Mac OS X 10.5 Leopard installed on your Mac.

Bookmarks
Bookmarks