Sign Up / Log In

Will My Mac Support OS X Yosemite?

Question:

How do I know if my Mac will be able to run OS X Yosemite?
- Asked by Reggie H. June 12th, 2014

Answer:

The easy answer is that any Mac running OS X 10.8 Mountain Lion or OS X 10.9 Mavericks will be able to run OS X Yosemite. Here's a complete list of Macs that will support Yosemite.

  • MacBook 13" Aluminum from 2008 or any MacBook from early 2009 on
  • MacBook Pro 13" from mid-2009 on, MacBook Pro 15" & 17" from late 2007 on
  • MacBook Air from late 2008 on
  • iMac from mid-2007 or later
  • Mac mini from early 2009 and newer
  • Mac Pro from early 2008 on
  • Xserve from early 2009 and newer
Filed Under: Mac, OS X Yosemite
Bookmarks
Bookmarks